breaking a php 5.0 class for backward compatible…

hey Drew, can you take a look at http://vbenhancer.com/vbe-complimentaries/statistics-tendencies/4955/ and see what you could do with the actual problem?… the class with the problem is the one to calculate the tendencies of each month, and it is written in PHP 5… i provided a start of fix for 4.3, but it does not work like planned, as i know nothing about classes…

if you think it does not worth the effort to make a 4.3 version, tell me, so i would tell the guy…

7 réponses sur “breaking a php 5.0 class for backward compatible…”

  1. no problem for the late reply, i’m in vacations too… lol

    i did not get it… the main error is related to the « private » state of the class… PHP 4.3 is not compatible with that and i have no idea how to handle that… if it is impossible, just tell me, the guy will wait… he said he would pay, tell me your price.. lol

  2. you read the thread?… actually i have no idea, but this is related to a specific line and when i put « var » instead of « private », the error move to a different location… i tried to tweak this, but i am null on classes… 🙂